Back to overview
Resolved

bexio integration unavailable

Jul 17, 2026 at 6:56am UTC
Affected services
app.aumico.io

Resolved
Jul 17, 2026 at 6:56am UTC

We’re having some trouble with the bexio integration. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.